Sport Bikes banner

1 - 4 of 4 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
I brought my daughter home from college the other day and rode her GS500 part of the way for her. The tachometer and the lights were flickering or shutting off completely while riding and when stopped the engine would either die or almost die every time. I got it home and thought maybe bad battery but it was a 3 hour ride so battery should have charged while i was riding it. Hooked it up to a battery charger and slow charged it till full. She rode it with no problems for 3 days before same problem, lights and tach stop working and when she came to a red light it died on her. Can charge the battery to get it around but need to fix this. Any ideas on problem or what to look at would be appreciated.
 

·
Registered
Joined
·
38 Posts
sounds like its barely charging, time to open manual and get a voltmeter to find out if its stator, r/r, or simply bad connection somewhere.
 

·
Banned
Joined
·
7,613 Posts
sounds like its barely charging, time to open manual and get a voltmeter to find out if its stator, r/r, or simply bad connection somewhere.
It could be the battery. I read about this a lot when people use battery tenders, as if its ability to hold a full charge is diminished. If a battery dies normally iys a bit more onvious and slower.

Sent from Motorcycle.com Free App
 

·
Registered
Joined
·
38 Posts
agree a battery that is unable to charge may create similar problems, but if it dies while running generally means a charging problem,
i am not familiar with the new ? gs500 i have an older gsx750
if you get it going battery could be removed as in stator would provide enough juice for the plugs to fire and electronics to run. im sure in the manual there is procedure on how to diagnose it?
easiest thing to do is get a voltmeter check that battery has at least 12.3v
start the bike and check the voltage at battery
rev it up a bit the voltage should increase a bit
rev it up more the voltage should increase agian but not exceed something like 14v

if you start the bike and voltage is not increasing than stator could be bad if voltage jump to high or is all over the place could also mean r/r.

once again the manual should say what voltage is suppose to be at idle and certain rpms
 
1 - 4 of 4 Posts
Top