Sport Bikes banner

1 - 8 of 8 Posts

·
Registered
Joined
·
769 Posts
Discussion Starter #1
hey guys. i've been riding my 500 for about a month now and everything is great until last night. before i went to my girlfriends house i went cruising for a bit and all the gauges worked fine. then when i left a few hours later my speedometer doesnt work at all. it just stays at zero and the miles dont get added on either. just wondering if anyone knows any thing about this and what i could check myself to fix it. its really bugging my. thanx
 

·
Registered
Joined
·
4,927 Posts
A lot of people have a problem with the speedo cable getting unscrewed from the back of the speedo. So anyway, you can unsrew/unbolt the upper fairing and just pull it forward enough to screw the cable back on after applying a liberal squirt of Loc-Tite.
Or you can squeeze your hand up under the fairing from the front of the bike and try it that way. I did it on the road the first time it happened this way and my wrists hurt bad afterward.
No biggie. If thats not the case, then you have a broken cable. If you do, PM me, I think I have a spare I'll sell ya.
 

·
Registered
Joined
·
163 Posts
probably just the cable coming loose, either take it to a shop or put some medium weight lock-tite on it so if you do need to take it off you can
 

·
Registered
Joined
·
769 Posts
Discussion Starter #4
ya it was the cable. so i solved 2 problems at once. one was the speedo not working and one was a rattling sou nd caused by the cable.
 

·
Registered
Joined
·
1,552 Posts
Yeah, my brother (newbief2) has been having that same problem...It keeps coming undone from where it connects to the speedo. I think a little thread lock would solve that problem.
 

·
Registered
Joined
·
38 Posts
I have only had my binke for about a week and my speedo cable came loose today on my way home from work. I just reached up their to tighten it Until i get a chance to take it apart and put some lock-tite on it
 

·
Registered
Joined
·
7 Posts
My '03 had that problem. I ended up torquing the crap out of the speedo end of the cable to keep it from vibrating loose. Locktite might have been a better idea.
 
1 - 8 of 8 Posts
Top