Sport Bikes banner

1 - 9 of 9 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
i gotta 98 zx6r ninja, i was changing the oil in it, got done, started it up and the oil light stayed on and it started knockin, i shut it right off. i got the oil pan off now, nothin is obviously wrong, and the pick up tube screen isnt blocked off, also the oil pump shaft does turn when i crank the engine, also before i tore it down i removed the oil filter and crank it with the coil wires off and very little oil leaked out...is there anyway it could have air locked or the oil pump lost prime soem how, i'd appreciate any info anybody can provide, and my email addy is [email protected]
 

·
Gordon
Joined
·
124 Posts
oil pressure?

Never heard of prolonged knocking after oil change, just a little until pressure
builds up.. Try putting some oil into the filter before re-attatching (not too much as it will leak back out if it's horiz.). :confused:
 

·
Industrial superstar
Joined
·
722 Posts
make sure you have the right filter. can't remember if that filter has a valve in it. If it does and your bike does not require it, it would stop flow.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
thanks for your replies.....somethin else i already done switch the new oil filter with the old one i was changing, and the new is the same kidn as the old oen also, (fram) i also did fill up the filter and then screwed it back on, i did that several times. everythign was fien untill i changed the oil.
 

·
Industrial superstar
Joined
·
722 Posts
Duno what to try next. Change the oil pump is all I can suggest. Just cause it's turning doesn't mean it's pumping...
 

·
Registered
Joined
·
1 Posts
Had this prob with my 99 zx6r when using fram filters, unscrew the filter a couple of turns from the bike so that there is a gap, start the bike till oil gushes out and tighten the filter, make sure the light went off and the knockin stops, then refill with the right amount of oil, and dont use fram anymore.
 

·
Industrial superstar
Joined
·
722 Posts
"dont use fram anymore" ......I was thinkin the same thing....
 

·
Registered
Joined
·
7 Posts
Discussion Starter #9
thanks for are the suggestions, i still have it tore down, im gonan take the pump off and check it anyway since i already have it tore down, then im gonna take a blow gun and shoot soem air through it, once i get it back together in the next few days (i gotta work now and no tiem spare time at all) i will try the unscrewing the oil filter with the engine running, also i'll trash that fram filter, iv'e heard of losing oil pressure in cars before when using frams but there much cheaper than a factory filter, plus thee closest dealership is 30 miles away. but if they cause this much trouble there not worth the money i saved by using them.....thansk again
 
1 - 9 of 9 Posts
Top