Sport Bikes banner

1 - 8 of 8 Posts

·
Just puttin' along
Joined
·
562 Posts
Discussion Starter #1
I have a 94 FZR600.The battery died on my recently, so I jumped it to try to charge it back up.It started fine and I rode around a while.When I got back I was checking it out and noticed the low beams were not working.I have dual headlights and both were out.Could I have burnt them out by jumping it off or could there be something else?
 

·
old member
Joined
·
13,079 Posts
I'd check the bulbs and fuses first. Most bikes with dual beams only light one on low beam. So one bulb may be single filament (high beam only) and one bulb dual filament (low and high beam). There may be separate fuses for low and high beams. Do the high beams work (both bulbs)?

Jumping it could have blown the bulb or fuse, but not likely. More likely it's just coincidence.
 

·
Just puttin' along
Joined
·
562 Posts
Discussion Starter #3
Yeah I do have a fuse, but it says head only. I assume if it were blown then the lights wouldn't work at all.Both high beams work.
 

·
old member
Joined
·
13,079 Posts
Then look carefully at the bulbs. If one is dual filament, I'll bet one filament is broken.
 

·
~ Master Technician ~
Joined
·
2,176 Posts
A while back both of my low beams went out. I checked the fuses, connections, bulbs and it ended up being the hi/low switch just needed cleaned.
 

·
Just puttin' along
Joined
·
562 Posts
Discussion Starter #6
2001FZ1 said:
A while back both of my low beams went out. I checked the fuses, connections, bulbs and it ended up being the hi/low switch just needed cleaned.
May be something to this I just noticed my horn wasnt working either. :confused:
 

·
~ Master Technician ~
Joined
·
2,176 Posts
red_devil1469 said:
May be something to this I just noticed my horn wasnt working either. :confused:
Does you bike sit outside or something? maybe corrosion has started to form. It would be a good idea to take apart the electrical connections, clean them with alcohol and then apply electrical grease on the contacts before reassembly. This grease can be bought at any auto parts store, it the stuff you put on spark plugs.
 

·
old member
Joined
·
13,079 Posts
Hmmm, low/high light switch and horn button are both on the left grip. You may have some dirty connection problems as mentioned above or a problem with some common wiring. Sounds like it may be time to take the grip apart and look at wiring and connections.
 
1 - 8 of 8 Posts
Top