Sport Bikes banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Im sure someone's seen this before but I've done basically everything I can do based of reading other posts online.

I am unable to get my bike to fire. It will crank but I do not get a file pump prime when I hit the switch. I do get the FI light on the dash.

What I've checked/done.
New battery.
Checked wiring to make sure everything is tight.
Checked fuses.
Checked BAS
More but I'll bring up if needed.

I don't know how to check my kill switch. I haven't tested my fuel pump either but all connections look great.

Here's what happened. I was not able to start it one day just would crank. Tried push starting it. No luck. Tried jumping it. No luck. Left trickel charger on it over night. I think that's when it started. So I assumed battery. Got new battery. Took me a few weeks to get the time to swap it. But still no prime. One day before I changed the batter I was riding around after about a half mile bike bogged down and died. Pushed it home. Put it on the charger. Finally started let run for a bit but then it died after 2-5 mins. Sense then I have a new battery.

Any help would be appreciated. New to motorcycles. Love riding but can't. Weather is starting to get nice in Colorado. Thanks
 

·
Mexican Hard Shell Taco
Joined
·
5,894 Posts
It won't crank if the kill switch is in the off position or if the kickstand switch was not working, so don't worry aobut those. The fuel pump should prime as soon as you switch the ignition on, if it doesn't, then that's your problem; you'll have to get a multimeter to check if the pump is getting power.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thanks After taking everything off the bike and testing the fuel pump with a battery I get nothing so I'm thinking it is just seized up and I ordered a new one.
 
1 - 3 of 3 Posts
Top