Sport Bikes banner
1 - 12 of 12 Posts

· Registered
Joined
·
157 Posts
Discussion Starter · #1 ·
i was riding yesterday and my headlight stopped working and signals were ALL one and not flashing i worked on the bike today and its still messed up and acting crazy.
- with headlights pluged in nothing works,
- with them unpluged the turn signals in fron are reversed and the rear signals both flash
- with headlights and front signals unpluged the rear signals are fine.
- used a tester and things all have power.

WAHTS GOIN ON???? could it be the relay by the battery or should i say screw it and take it to a dealer?
 

· Banned
Joined
·
3,015 Posts
Have you checked the fuses too??
 

· Suzuki 3000GT
Joined
·
2,108 Posts
Have you tried powering the wires through a seperate battery?
 

· Registered
Joined
·
65 Posts
Check your wires, they might be grounded out. My buddy was riding his 02 f4i a was having problems starting his bike. Found out one of the blinker wires was grounded out. Wierd shit
 

· Registered
Joined
·
364 Posts
03suprchikn said:
Check your wires, they might be grounded out. My buddy was riding his 02 f4i a was having problems starting his bike. Found out one of the blinker wires was grounded out. Wierd shit
LOL, I had this same exact problem your buddy did. Ended up when the blinker light went out. The little wire inside the bulb crossed over to the other one and shorted out my whole bike. I just replaced the blinker bulb and it was good again.

I wouldnt doubt that replacing you're headlight bulbs would fix the whole thing.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top