Sport Bikes banner

1 - 6 of 6 Posts

·
Registered
Joined
·
181 Posts
Discussion Starter · #1 ·
I have a problem with my 2002 zx9 that the dealer has not been able to figure out. Maybe you guys can help.

Under certain conditons (usually high rev or hitting a big bump) both headlights go out totally (no hi or low beam but the city light still works) unitl I come to a complete stop or bring the revs down low. The headlight switch also no longer works when this happens. Has anyone seen or heard of this problem and have a fix? The dealer states that he double checked all connections, etc. and even put it on the dyno and could not reproduce the problem. This has happened a couple of times an NIGHT. I've changed the junction box and both headlight relays and the problem still exists.

TIA
 

·
Registered
Joined
·
452 Posts
Have you tried replacing the bulb? If the filament is loose, it may go out when the bike hits a bump or the vibrations from the RPMs get high.
 

·
Registered
Joined
·
181 Posts
Discussion Starter · #3 ·
sjlee said:
Have you tried replacing the bulb? If the filament is loose, it may go out when the bike hits a bump or the vibrations from the RPMs get high.
yup. replaced both bulbs, forgot to add that.
 

·
Registered
Joined
·
2 Posts
I had alomost an identical problem, it just seemed more intermittant. Checked everything but every time I tried to test it, it worked. I finally decided to change the nearest connection. (lots of wires) I went to Radio Shack and bought a 12 PIN connector. Problem solved!!!!!

P.S. I shook that wire harness a million times trying to find a loose wire to no avail.

Steve Krytus
 

·
Registered
Joined
·
181 Posts
Discussion Starter · #5 ·
f150gsxr750 said:
I had alomost an identical problem, it just seemed more intermittant. Checked everything but every time I tried to test it, it worked. I finally decided to change the nearest connection. (lots of wires) I went to Radio Shack and bought a 12 PIN connector. Problem solved!!!!!

P.S. I shook that wire harness a million times trying to find a loose wire to no avail.

Steve Krytus

What connection did you actually change? The one closest to the headlights? Did you just splice in and change the connector?
 
1 - 6 of 6 Posts
Top