Sport Bikes banner

1 - 17 of 17 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
Bike would not start, after 5 seconds an error code came up "F1" or "FI" on the temp gauge, red light flashed continuously! :(
 

·
Industrial superstar
Joined
·
722 Posts
it's your fuel injection warning light. A number of things can set it off. I can look in my shop manual and list them for you when i get home from school.
 

·
Registered
Joined
·
29 Posts
Discussion Starter #3
Thanks bro ,I would appreciate the help! BTW the bike is running now ..
had to reset ECU!
 

·
Banned
Joined
·
144 Posts
I know what is wrong with it......... It's a GSXR HAHAHAHA. Just kidding man. Most of the time it is because one of your injectors is clugged causing an uneven flow. Throw some fuel system treat ment in at the next fill up run it threw in one day then take your tank off and look at your injectors. I bet you'll find them to be very clean.
 

·
Registered
Joined
·
10,767 Posts
you can go to gixxer.com and look up the FI codes there if you do the dealer mod. and hopefully it will help you out some
 

·
Registered
Joined
·
29 Posts
Discussion Starter #6
M24SWS said:
I know what is wrong with it......... It's a GSXR HAHAHAHA. Just kidding man. Most of the time it is because one of your injectors is clugged causing an uneven flow. Throw some fuel system treat ment in at the next fill up run it threw in one day then take your tank off and look at your injectors. I bet you'll find them to be very clean.

Thank You! :)
 

·
Registered
Joined
·
966 Posts
This was a problem on the 01 also, what I was told by my delearship while I lived in Vegas that a hot blast of air going into the intake would set off the FI light, he said pull over and shut if off restart and see if it goes away.....kinda wierd.
 

·
Registered
Joined
·
402 Posts
Grab a paperclip.

Place the bike in Neutral, and take the rear seat cowling off. On the side of the bike between the tail section and the trunk you will find a connector that is covered by a rubber cap, and has two wires running into it. Remove the cap and take note of which one of the 4 sockets the two wires go to. Turn the bike ON and start it up, short the wires out with the paperclip. Where your speedo was flashing a -CHEC- with the temp should now be a CXX error code. Write this code down. Then shut the bike off. Match the code up with the list below. Grab a Manual and get to work!

(What you have just done is put the bike into "Dealer Mode". I think it's a gimick implemented so that you have to take the bike in and pay $60 for a diagnostics fee.)

GSXR Fuel Injection (FI) Code List:

C14 - THROTTLE POSITION SENSOR
C15 - ENGINE COOLANT TEMPERATURE SENSOR
C21 - INTAKE AIR TEMPERATURE SENSOR
C22 - ATMOSPHERIC PRESSURE SENSOR
C23 - TIPOVER SENSOR
C24 - IGNITION SIGNAL #1
C25 - IGNITION SIGNAL #2
C26 - IGNITION SIGNAL #3
C27 - IGNITION SIGNAL #4
C28 - SECONDARY THROTTLE VALVE ACTUATOR
C29 - SECONDARY THROTTLE POSITION SENSOR
C30 - SECONDARY THROTTLE CONTROL UNIT
C31 - GEAR POSITION SENSOR
C32 - INJECTOR SIGNAL #1
C33 - INJECTOR SIGNAL #2
C34 - INJECTOR SIGNAL #3
C35 - INJECTOR SIGNAL #4
C41 - FUEL PUMP CONTROL SYSTEM
C42 - IGNITION SWITCH SIGNAL
C46 - EXHAUST CONTROL VALVE ACTUATOR (1000 ONLY)



* I Predict a C28 Error which is one of the most common among 2000-2001 model GSXRs. The Secondary Throttle Valve was controlled by cables during these years instead of just bolting the unit dirrectly to the motor. The cables tended to fray around 20k miles or so. It's a relatively easy and cheap fix. 2001 they coated the cables in a plastic sheath which helped to solve the problem. If this is indeed your problem it will run you all of $18 for BOTH cables (if you need them) and about a half hours worth of work. Let me know if you need more assistance!
 

·
Registered
Joined
·
2,722 Posts
His bike would have still started if it was c28 error code.

By the way you are missing the error codes for Crank Position Signal Sensor.

That would have been my guess, if his bike was indeed not starting, CPS error.

Either that or TPS, or Tip over sensor faults.
 

·
Registered
Joined
·
29 Posts
Discussion Starter #10
Well I did What "lun" said and came up with "c00" which i,m guessing means
there are no errors right now, Makes sense (I reset the UCU to get it to start)
probably just throw some injector cleaner in and wait for it to happen again!

Thanks for all your help guys!!! :cheers
 

·
Registered
Joined
·
2,722 Posts
c00 indeed means thats everything is ' coo '

bad joke, but at least your bike should be running ok.
 

·
Registered
Joined
·
402 Posts
the C00 Is the standard code if nothing is wrong with the bike. Infront of the C00 there is a line that can have one of three positions.

_C00 -C00 ¯C00

This tells you what position the Secondary Throttle Position Sensor (TPS) is in.

Look at the code to make sure that the indicator is in the middle ( -C00 ). if it is lower your TPS is turned too far back. If it is higher, your TPS is turned too far forward. If all is well and your FI light is still on or the bike does not run, let me know. I'll need more information to further assist you. :)
 

·
Registered
Joined
·
29 Posts
Discussion Starter #13
The light is off now it only came on that one time when it wouldn't start.
after I unplugged the ECU and reattached it the bike started fine and It has not done it again, that was a week ago! (-c00) position :)
 

·
Registered
Joined
·
402 Posts
Well, Sweet! carry that paper clip in your trunk or something. If you get the FI light again pull over, leave the bike running and put it in Neutral and Put it back into 'Dealer Mode'. If you shut the bike off, it will clear the FI code and you may not be able to find out what it was.


You can also purchase a switch (or make one yourself) from http://www.jsdproducts.com/Product_Info/product_info.html
 

·
Registered
Joined
·
2 Posts
Havin similar probs with an 01 cbr 929. The bike wont start and the fault codes flash in the this order: 1 blink pause 2 blinks, 1 blink pause 3 blinks and 1 blink pause 4 blinks. Not sure whats up. It was showing 9500 miles when I bought it a week ago and now its showing 15000. Any ideas?
 

·
Registered
Joined
·
10 Posts
Fi C22

Hello,
Im fairly new to this site and i came across this thred. I followed the instructions on getting the code and i got ¯C22 which ii believe its the atmospheric pressure sensor. First where is that sensor located and second "¯" is the TPS if im not mistaken how to i adjust it? If somebody can help me out because i am stumped o_O
 
1 - 17 of 17 Posts
Top