Sport Bikes banner

1 - 2 of 2 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter · #1 ·
I bought used 2009 GSXR 600 a year ago from a dealership. A few months into riding it, I noticed the gauge cluster started to short out. It would take out the entire gauge cluster (except the neutral light), both front turn signals, and the headlights.

I took off the left fairing and found a black box, which I found out to be a LoJack. I thought that was the cause of the issue, so I removed it and everything started working fine..up until a few months ago. I assumed that it was related to the wiring that was tapped for the LoJack.

I finally had the time to get my hands dirty and remove the fairing again to inspect the wiring. I found some burns in the wiring harness connectors, and I'm curious how severe this damage is...along with how can I fix it.

I've attached the images and I appreciate your help.





 

·
Banned
Joined
·
7,613 Posts
If you go to an electronics store, you should be able to find the terminals and hopefully replace it. There arent a lot of good electronic stores around anymore though. Maybe if you get lucky, youll find a radio shack where there are good employees, where they might be able to guide you in the right direction.

I wouldn't worry about what it is, and would just fix it, and look for other connections that have been altered since it arrived from Japan. A lot of do-it-yourselfers "think" more than "understand" how to make good electrical connections. Look for non-OEM modifications.

I would like to know what that terminal is, because I'm guessing some mod tapped that line for a power source, and the arcing was caused by high current.
 
1 - 2 of 2 Posts
Top