Sport Bikes banner

1 - 3 of 3 Posts

·
Registered
Joined
·
56 Posts
Discussion Starter #1
My bike, 1994 ZX6E, wont start anymore. it began in the cold if I moved the key and the oil light didnt flicker right away it wouldnt start all that happened was the started kept moving but the engine wouldnt start, then i would have to flip it on and off until it wanted to start, it stopped over the summer now in the winter it was doing more only in the cold of course, i figuered it was the ignition switch and it must just be it. I took the bike apart today because a few days ago it wouldnt start hot or cold, thats how its like now. I moved all the wires around took apart the lock cylinder/switch nothing same problem someone suggested checking each wire for voltage but i dont have a voltage tester thats what im going to do next its pissing me off i cant [email protected]#$ing ride anymore! if i cant figure anything out i have to take it to the shop.
any suggestions?
 

·
RESIDENT ASSHOLE
Joined
·
8,497 Posts
Sounds like you already figured it out but you would rather waste your time trying to beat a dead horse, just replace the lock set and be done with it. You cant alway reliably fix switches, they do end up at a point with diminished returns. Its a wearable part as with most of your bike.
 

·
old member
Joined
·
13,079 Posts
You could try contact cleaner on the ignition switch contacts (carefully). If the contacts are dirty that will likely help at least for some time. If the contacts are worn, cleaning them may make a difference but only for a short time and it would be time to replace the switch module.
 
1 - 3 of 3 Posts
Top