Sport Bikes banner

1 - 5 of 5 Posts

·
Registered
Joined
·
93 Posts
Discussion Starter #1
My bike wont start, its a 94 zx6 . I'm pretty sure its the batter but im just checking.


Well yesterday it started fine the whole time for a good 2 -3 starts but it was a warm start. So this morning i wake up and go out to start it and turn the key and make sure the switch is turned to run and then it cranks and it sounds like its about to start but never does.

At this point i go back inside for a few minutes come back out and try it again. It just turns over and doesnt sound like its going to start so after a while of this it just stops.

Now it makes a clicking sound like the starter isnt getting enough to turn it over and the lights on the bike flickers and dies off and on.

So do i just need another battery or can i charge this one?
 

·
Registered
Joined
·
103 Posts
Sounds like you killed the battery trying to start the bike. It should be recharged.

Did you use enough choke to start the bike this morning?

BTW: don't jump-start your bike. Instead, charge the battery.
 

·
Sub-Zero
Joined
·
922 Posts
do u put the thing on choke everytime u start? or when it is cold?
 

·
Registered
Joined
·
93 Posts
Discussion Starter #5
Well i found out that i needed a new battery. The one the guy put in it was just an used one. We already jump started it though. First we tryed push starting it but that was a pain in the ass and didn't work.

Thanks for the help though,
Brian
 
1 - 5 of 5 Posts
Top