Sport Bikes banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1 (Edited)
I hav an '04 Arai Astral... and not too long ago, one of the side pods broke off, and i called Arai, and they gladly sent me another one for free. When i got my new one i tried to put it on, and for some reason i cant get it. When i go to push down the bottom tab.. the little red part of the helmet pushes outward and locks and it wont snap. Then i push it back out and try again and it does the same thing... Ive tried almost everything and cant figure out the problem. Can someone plz tell me if there is something i am doing wrong.... and/or there is another way to put it on im not trying... thanks for your help..
 

·
Registered
Joined
·
539 Posts
hmm.. If it's like mine, you have to slide the back latch on first, then push the front ones in. Then again I have signet. Might be different.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Yeah the astrals are different.... on these there is a latch on top and then a latch on bottom... i appreciate the effort tho... thx.... is there anyone else that has any ideas at all???
Thanks
 

·
Registered
Joined
·
250 Posts
I had a similar problem with my Corsair.

When Arai sent the replacment... I went to the local Arai dealer and had them put the pod cover back on... I figured if they broke it, then they'd replace it.

Basically, the guy put the top tab in and then just whacked it until the bottom one snapped into place.
 

·
what R you lookin' at?
Joined
·
5,313 Posts
when replacing lenses, i lay a towel down or place it something soft......my seat of on the road.

lay the helmet on 1 side, and press down on the plate-side that i'm taking off. while pulling on the tab. and same for the other side.

had my side plate pop off 2-3x in 5-6 yrs of wearing arai lids.
 
1 - 6 of 6 Posts
Top