Sport Bikes banner

1 - 20 of 31 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #1
o i was riding along and all of a sudden it felt like i was deaccelerating in like 2 second intervals almost like it had fuel, then no fuel. then i down shifted to get it into a gear to up the rpms... wel as soon as i took it out of gear and the rpms dropped it died! waited a minute and it started again so i started heading for home sure enough same thing happened 1 mile later. so i pull over look at the fuel lines... there is fuel... but then i saw something float in the fuel line in the hose right below where you change it from "Reserve to ON" ect it went up into the place where you choose where the fuel comes from? so finally it started again but as soon as i pulled int my neighberhood same thing!

this is terrible i just got the stupid thing:(

could this be something coming from out of the tank? or maybe something else please help me!
 

·
what R you lookin' at?
Joined
·
5,313 Posts
reserve tank? debris in tank? water in tank?
 

·
Registered
Joined
·
44 Posts
Discussion Starter #6
how do i check to see if its getting ventilated.. i assume since there is fuel in the line its getting fuel
 

·
Registered
Joined
·
533 Posts
run it for a little and than open the gas cap and see if there is pressure, like u go to open it and see if u cant because suction
 

·
Registered
Joined
·
5,217 Posts
check the tank for rust. my old ex500 had a rusty tank, so i had to replace the petcock(the part where u switch to on/off/reserve) assembly and fuel filter cuz it got clogged up.

edit, the parts i mentioned replacing were cheap
 

·
Banned
Joined
·
912 Posts
sound like the engine is being starved for fuel. I'm thinking you have something in your lines or your tank is not breathing right!
 

·
Registered
Joined
·
44 Posts
Discussion Starter #12
well i cant do the fuel tank opening thing i only have 1 key atm. the guy i jsut bought from said when i bought it there was no rust in it atm and as a matter of fact it had a coating of that anti rust whatever it is. i truely believe the guy to be honest so... the bike was jsut apart due to the fact he just painted it... could it have been an air bubble rather then an object? and what could that mean? ill go check to see if i see any hoses crimped
 

·
Registered
Joined
·
343 Posts
he just painted it... well I have heard that if you sand blast your tank that it's nearly impossible to get all the sand out... so maybe that's what's causeing it...:dunno just a guess though...
hope things sort out for ya

:cheers
 

·
Registered
Joined
·
533 Posts
well just run your bike for a little, let it warm up and just rev it a little, take the key out and open the cap, see if it has suction

the air vent hose on my r6 was jacked up and it wasnt being ventilated, it made it die and i couldnt figure it out, but i opened the cap and i heard it suck in a bunch of air
 

·
Registered
Joined
·
6 Posts
I had a similar problem with an fzr I had, it would run fine then cut out and when I would pull the clutch in to down shift it would die.The problem ended up not being a gas problem or lack there of, it turned out to be the "brain" on the bike.Once the bike warmed up it would cut off. I would suggest cranking up the bike letting it run untill it cuts off , then pull a plug wire to make sure it's still getting spark.it may not be he problem but it's worth checking out..
 

·
Registered
Joined
·
44 Posts
Discussion Starter #16
well i jsut filled it up at the gas station.. im not sure how much gas a 1990 gs 500 holds but on the sidestand it got 3.2 gallons... could i have been low on fuel?

i mean i looked in the tank but i could see gas so i figured i was fine??
 

·
Registered
Joined
·
343 Posts
I'd check with the old owner to see if he sand blasted the tank... like I said before I've heard that the sand is nearly impossible to get out... and like we all know... sand and gas make a nice clog...
 

·
Ducati Twins Rock
Joined
·
267 Posts
500dreams said:
well i jsut filled it up at the gas station.. im not sure how much gas a 1990 gs 500 holds but on the sidestand it got 3.2 gallons... could i have been low on fuel?

i mean i looked in the tank but i could see gas so i figured i was fine??
After you filled the bike with 3.2 gallons of gas, did the bike run normal or not?
 

·
Registered
Joined
·
926 Posts
snigg said:
replace the petcock(the part where u switch to on/off/reserve) assembly and fuel filter cuz it got clogged up.

edit, the parts i mentioned replacing were cheap
+1, real easy fix too.
 
1 - 20 of 31 Posts
Top