Sport Bikes banner

1 - 5 of 5 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter · #1 ·
This is a friends bike that lives no where close to me that is having the issues.

During a ride yesterday after finishing up at their stop he started his bike up, no issues. As soon as he puts the bike in gear it stalls and lurchs forward slightly. My first thought was it may be his side stand switch. I told him to disconnect the side stand switch and jump it with a paper clip to see if this solved the issue. No luck.

I'm now leaning towards the possiblity that his gear sensor has gone bad. He does get a nuetral light and it does go out when put into gear. I was also thinking clutch switch, but I know Suzukis require the clutch to be pulled in to start so unless there is a seperate component to the switch I don't think it's the issue.

He drained the oil and did a "visual" inspection of the clutch and said nothing looked abnormal (although he is not too familiar with clutch components). He did not dissasemble the basket.

He's also tried adjusting the cable on both ends with no success. He claims the bike will not roll forward or backwards with the clutch pulled in and in gear. In nuetral it rolls normally. To me that seems to generate the idea that the clutch is in someway not fully disengaging.

Does anyone have any thoughts? Just trying to help a friend with some diagnostics. Thanks for any input!
 

·
Registered
Joined
·
2,274 Posts
I would go for the fact the neutral light stays on as being the issue right there . Most bikes are hard work to push with the clutch pulled in while in gear as you always have some drag .
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #3 ·
I would go for the fact the neutral light stays on as being the issue right there . Most bikes are hard work to push with the clutch pulled in while in gear as you always have some drag .
I guess I don't understand. The nuetral light is on when in neutral. When he puts it into gear the light goes out, like it should.
 

·
Registered
Joined
·
2,274 Posts
I guess I don't understand. The nuetral light is on when in neutral. When he puts it into gear the light goes out, like it should.
No not your fault I read it wrong . But I would bank on it being one of the cutout switches . If the sidestand tests as good then it likley the gear one .
 
1 - 5 of 5 Posts
Top