Sport Bikes banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
i have a zx10 2004 and I am having mechanical issues with it.
WHAT IT IS DOING: it started out bogging out at 9000 rpm only in full throttle, and after I back off the gas it gets a huge power boost and about jerks me off of it. under 9000 rpm it runs fine, with the exception of today when I was on the way home and it started sputtering and bucking right below half throttle. I took it to the dealership and they blamed the voltage regulator even though it was charging just fine. one dealership mechanic said it was putting too much voltage and melted a few wires (which he said he fixed) and another dealership mechanic said it wasn't putting enough voltage and all he did was replace the regulator. the problem got better, now it slowly climbs above 9000 at full throttle(takes about 3 seconds to get from 9000 to 9500) but still bucks when I back off the throttle like it is finally got what it was lacking. it has a little noise in the top end but its sounds like a slight rattle. it also runs a little hot now and then. It also pops from the exhaust just a little bit but the cord to the exhaust valve is cut so theres no back pressure.
WHAT I HAVE DONE: changed the fuel pump and filter, run seafoam through it, had that work done at the dealership( described above), changed the spark plugs, cleaned the air filter(KandN air filter), changed the oil, replaced the battery, taken apart the kick stand switch and checked for water (also put the bike in first with the clutch in and shook it as much as i could and didnt do anything) and removed the secondary throttle bodies(after it messed up)


Anybody got any other ideas?
 

·
RESIDENT ASSHOLE
Joined
·
8,497 Posts
No power commander?

Sounds more like the ecu doesn't like a wide open throttle at high rpm because of a sensor giving a false reading.

No error codes?

I'd check all inputs and repair accordingly
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
It Gets Worse At Higher Gear, By Sixth It Bogs Out Completely At 7 Grand At Any Throttle. There Is A Small HoLe In The Cdi Where The Idiot I Bought It From DrOve a Drywall Screw In The Inner Fairing And Poked It, That's What The Dealership Said Anyway, They've Had It A Month And Worked On It Pretty Much Every DaY And Still Can't Find It
 

·
Supersquid
Joined
·
1,127 Posts
find a local guy with same bike and swap everything till it's gone, the dealership is doing the same thing only you're paying for it.
 
1 - 5 of 5 Posts
Top