Sport Bikes banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I picked up an 03 GIXXER 750 from a buddy knowing it had this issue, price couldn't be beat. I figured, how hard could it be? Well I'm completely stumped. Here's the problem; start the bike from cold, it idles on high idle without stalling, however you can hear slight abrupt misfires if you have the ear for it (a non-motor head type would probably never notice it). Once the bike is ridden and gets up to about 170-180F if you pull up to a stop with the clutch in the thing just wants to die. I have to feather the clutch like nothing I ever had to just to keep the thing running (people are probably like looks at this rook!). Above about 4K the bike runs mint and pulls happily without a hiccup all the way to redline. Come to a stop and it misfires like crazy and dies. Here's a list of things I've tried in an attempt to remedy this; Drained tank, fresh gas. Plugs are new. K&N air filter is clean. Cleaned the throttle bodies. Ran fuel injector cleaner through it. Adjusted the TPS multiple times in and out of -COO. Pulled fuel pump apart, cleaned screen and "sump" where screen sits. Ordered a used TPS (new ones don't seem to exist), installed/adjusted and it behaved the exact same. Installed 4 new coils, same. Installed 4 remanufactured fuel injectors, exact same behavior. I went as far as to pack the area around the ECU with ice in a bag, same. I about ready to roll this thing off a cliff but really want to get it to 100% so I can actually enjoy riding it.
Please Help!
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
As an aside, if you search this problem and use "herky jerky" you'll see many other people with seemingly the same issue. I have yet to have found a solid remedy.
 
1 - 2 of 2 Posts
Top