Sport Bikes banner

1 - 9 of 9 Posts

·
Registered
Joined
·
68 Posts
Discussion Starter #1
Hi, I will give you a quick history, the bike ran great, the kid played with the oil injection and then it would not run, it then sat outside for about 2 to 3 years. Today he brought over and we drained the gas tank, oil injection tank (both filled with water the tank was not rusty inside) blew out all the lines. We took the carb apart, it was filed with crud and cleaned it up the best we could and got everything freed up. we then put it back together and put a 40:1 mix (amsoil) in the tank (we did not use the oil injection yet) and dragged it with the quad after a while it ran but only at full throttle. we put some amsoil injection oil in the injection tank but have not tried to start it since putting it in. it may run rich now but I want to make sure that the oil is going to go thought the pump ( we did not tank the pump apart). If anyone could help that would be great, when should the oil pump though? how do I know if the pump works? how to I make it run and idle? I don't know what to touch on the carb? there is a went hose that comes out of the crank and that spit a little motor oil out of it. please give me some things to do and how to do them. Thanks a lot

P.S I was wondering if anyone knew the gap for the plug? Also what oil do i put in the crank case? reg motor oil? bike oil? weight? How do i go about adjusting the carb?is there anything I can do about a leaking seam on the tank? Thanks
P.S please keep the ideas coming I would love to get it running.
 

·
Registered
Joined
·
13 Posts
I bet your crank seals are bad and thats why it won't idle and run at low RPM. More than likely it smokes real bad too. That is the transmission oil being drawn in by vacuum into the crankcase past the seals and being burned the the air/fuel mix. You could have a mechanic do a leakdown test to verify if the seals are bad. Use a regular 4-stroke 10w-40 for your trans/clutch. Every thing else in the engine is lubed by the premix. Do a little web searching on 2-stroke carb tuning and you'll find a wealth of info.
To replace these seals involves removing the magneto and clutch assembly. You'll need a puller.
 

·
Registered
Joined
·
519 Posts
to test if your oil injection is good...put reg gas in the tank and fill the oil tank with premix oil, then get it started and rev it up...if it smokes like a 2stroke its working...if it doesnt then it isnt getting oil...just dont rev it for very long if you arent getting smoke because then the top end is not getting oil to lube it and thats bad

i know its a ghetto way but it works
 

·
Registered
Joined
·
167 Posts
KICK ASS BIKE!! 75cc 2 stroke ...3 spd. semmi auto with centrifugal clutch.
My first bike ever!
Likely crank seals shot(cracked). Also check carb wear in the jets and needle region. This is an OLD bike!!
 

·
Registered
Joined
·
68 Posts
Discussion Starter #5
Can I use regular car 10W40 motor oil?
 

·
retired from here
Joined
·
4,122 Posts
first pull the carb back off, take it apart and soak it in carb cleaner for several hours. while it is soaking check the points and compression.
 

·
retired from here
Joined
·
4,122 Posts
BLACK Z said:
Can I use regular car 10W40 motor oil?
in the trans...yes
in the injector...no
 

·
Registered
Joined
·
68 Posts
Discussion Starter #8
Where are the points? I cleaned all of the electical parts I found. and after I find them how do i clean them? adjust them?
 

·
Registered
Joined
·
681 Posts
If nothing else, get a Clymer manual for the bike. It'll help.
 
1 - 9 of 9 Posts
Top