Sport Bikes banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
My buddy laid down my bike and he broke the stator cover, I replaced it and thought it would be fine. I put oil back in it and went to take it for a test ride. I got about 1/2 mile down the road and the oil light came on and befor i could do a thing I heard a snap nosie for under the seat. I got to the side of the road and tried to start it you can hear the starter spining but its not turning over the engine. I took the cover off and turned the starter over and it will spin and turn the gear that is behind the magnet but its not turning the crank. The bike only has about 6000 miles on it. Any have a idea what could have broke and what i could do to fix it thanks
 

·
Registered
Joined
·
21 Posts
:bananaBUMP!:banana

Honestly I am not a motorcycle man yet, so I don't have a qualified answer for you.

I wanted to give this thread a bump, because I am curious to see the more experienced members chime in.

If it is anything like a car's engine,... then I would say that either the crankshaft is broken, or that the flywheel somehow came disconnected from the crankshaft.

Sorry to hear about your luck. If it is related to there not being oil in the engine at the time that it failed, is there some kind of a crankshaft main bearing on the end of the crankshaft, next to the case and the crankshaft oil seal; and if so how does the ring-gear for the starter attach to the crank outside of the case? Is the flywheel on that end of the crank, or on the otherside of the engine? This is the part I don't understand... so I can't say what is broken

Miltman, I think that you and I both need to buy a ZZR Shop Manual -but none the less I am curious to see what can be said by someone who understands motorcycle engines better than I.

Best Wishes,

Alex
 

·
Registered
Joined
·
1,255 Posts
I've had an old 70's yamaha 250 dirtbike and the same thing happen but it was the magnito with the points a condinser ol'problem


the the engine stalled and the flywheel/magnito went spinning with out the motor moving. it turned out it was a special "I" shape pin that connected it with grooves to the crank. the pin broke. I'M NOT SURE IF THIS COULD BE IT. take it to the shop but take a lot of money. an engine is about $1500 used.

p.s I NEVER found the correct pin for the 250 so my mom gave it away :( because I stressed out to much trying finding the part
 
1 - 3 of 3 Posts
Top