Sportbikes.net - Reply to Topic
Suzuki Sportbikes GSX-1300R - Hayabusa, GSX-R1000, GSX-R750, GSX-R600, TL1000R/S, Katana, GS500F, Bandit, SV Series, RG500

Thread: SET Valve Mod Question K6-K7-K8 600/750 (Updated w/K5-K6 1k info) Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Sportbikes.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
03-11-2013 03:14 AM
stariondriver so what happens if you pulled all the set valve stuff with the bike off? I dont know it mine was opened or closedwhen i disconnected if. Does the ecu think its closed and have an effect on the fuel / timing?

this is on my k3

i see the bugman site say to short the feedback plug...
08-20-2011 03:38 PM
chopperider Hi,
Just joined this site after reading this thread..i have an 2006 GSX R600 and was having same problem with the FI light,, code46..
followed the instructions and problem is fixed!!! Thanks...
Question is,,,is the the light only dis-abled for a code 46 ??
It will still come on if some other problem happens , correct?
06-03-2011 03:10 PM
Schm
Quote:
Originally Posted by genes81 View Post
My bike didnt like this mod at all..It was louder but the rpms wouldnt get up over 6500-7000..I called the dealer and they told me the only thing they could think of was that they overserviced my engine with oil, or the exhaust control valve was not working and it wasnt creating enough back pressure to make the power....the oil level was fine and sure enough, I put the mods back to stock and it ran like a champ...not sure why it did this, I know the set valve was in the open position, i counted the cycles and I even took off my exhaust to make sure I did it right..oh well!

Just did mine and it did the same thing so i looked at it more and what i did was when you first turn the key it fully closes the valve then fully opens it! i pulled the plugs when it was fully closed and it would not go over 6500 to 7000 but now i got it right bike is louder, smother throttle, pulls a little harder
06-08-2010 04:44 PM
goldengixxer10
thanks so much for mod instructions

i just did my set valve mod and its freaking awesome at first i had a problem with turn the ignition trying to get it to stay open bc one of my cables were loose so any i continued to the next steps so wheni finished i started the bike and it didnt sound any different but theni just thought it was bc i just have a loud exhaust any way but then i just thought let me try a pair of channel locks on the wheel that open aned closes and so nough my valve was closed and as soon as i turned the channellocks the other way i could hear my exhaust get LOUD!! but for some reason my valve turns clockwise to open no counter clockwise but anyway man thanks for the help
2007 suzuki gsxr 750
05-30-2010 11:24 PM
jk750



05-21-2010 03:40 PM
waytofastmp I have a yosh exhuast and thought i would try this mod out. Performed this mod last night only took 12 mins. One thing you want to do to pull the #30 wire out is to remove the grey colored keeper on the back of the plug (this is the plate that has the #'s marked on it). just use a baby screw driver to pry it back. (you will see a notch to do this). If you do this you can pull the wire out with your fingers. Test road it today and it is alot smother in the lower speeds. It does make the big have a deeper sound and that pesky F1 light is finally gone. Thank you very much for posting this mode. My GSX-R has never run better.
03-19-2010 07:44 PM
FZGSXR06 It worked.! Thank you soo much. Oh ya, I used heat shrink tubing, works well.
03-04-2010 09:21 PM
rich91732 Hey guys hopefully you can help me out. I am a dumbass and pulled out the wrong wire. I pulled out #22. In the process of pulling it out the wire also broke less than an inch from the pin connector. I have spliced the wires back together with a connector and am trying to put the pin in but it doesnt seem to be catching. What do i need to do to get it to stay in the wiring harness? Any help would be greatly appreciated.
02-26-2010 10:57 AM
dragon eyes just got my new exhaust n pc. now just gotta wait for my acl brace to come off. then its game time.
02-26-2010 10:50 AM
godfather1317 Done with mine... So easy... a caveman can do it!... (No caveman's were harmed during the making of this post). Will ride it in a few days, after i finish installing the Yoshi TRC slipon and will post results. ;-)
02-14-2010 04:09 PM
dragon eyes is it the five pin on the 09 750 as well. cant find the answer and not lookin to do it blindly
05-23-2009 01:59 PM
xtremekramer
completed

Well all in all it took about an hour. Almost all of it was trying to get the plastic tail piece off! There is a screw that i was having a hard time getting to break loose at the weird angle you have to attack it at. It's been raining here pretty much non stop the last few days. Hope to get out to ride it this weekend. Took it down the street and back just a few minutes ago. Seemed to stumble when i first got on it. Other wise was doing fine. Will be curious if that goes away once the bike runs for a bit and the computer relearns the system performance. It was raining so i didn't get to really test it.
05-21-2009 09:02 PM
jk750 It's definitely a noise control solution. It says so right in Suzuki's first generation SET valve literature. An added benefit might be improved low speed torque, but that is not the reason for the valve.

If the low speed torque improvement was so advantageous, Suzuki, Yamaha and the others would be using them in racing to get the drive out of the corners with the Ducatis.



05-20-2009 07:35 PM
xtremekramer So I am about to do this mod since the damn FI light has been on for weeks. Seems like most of you have been happy with the results. Has any one noticed any difference in the low end torque after the mod? The service manual states this is the purpose of the valve. I know most of us agree its for passing sound tests...however being an engineer it makes sense you would loose some low end torque with the difference in back pressure. Just wondered if it was even noticeable? Or if noticeable the added throttle response made up for the difference in low end torque that that was lost that you just don't care about it?

I will let you know how it goes once i get mine done. Figure it can't hurt since the dealer wants to replace the motor saying it will take two hours of work at $75/half hour plus the cost of the motor. Figure a free mod is well worth a try.
02-12-2009 04:13 PM
prodigal27 Prior to this mod, did anyone have any abrubt studdering at times? My bike would act like it was choking mid-ride some times, just wondering if they might be related. Tended to happen in 4th/5th gear 7-8k rpm. Just a little hiccup then it'd be fine, but enough to scare me a little.
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome