Need help troubleshooting my bike ('06 GSXR 600). :( - Page 2 - Sportbikes.net
Help Me Fix It A great place to post any problems you may be having while working on your motorcycle. Most of us are do-it-yourselfers so this is a great way to share any information pertaining to fixing something or adding something on.

User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #16 of 16 (permalink) Old 02-07-2013, 07:28 PM Thread Starter
Now an official Cyborg...
 
Join Date: Jan 2002
Location: Deltona, FL
Age: 45
Posts: 235
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Sorry guys, I got bummed and let the bike sit for a while untouched.
I just fixed it though.

Ok, turned out to be the regulator/rectifier. I bought one off ebay and it fixed the problem.

During the process I accidentally swapped two connectors in my tailsection (still not sure what extra one goes to its white and triangle shaped) which caused me to pop a fuse. That fuse in turn killed the cluster. Once I saw what I had done I connected the correct connector and my fuel pump again worked.

Longtime member who has just returned after getting back into bikes. <---Just look at that join date! :)

Founder, financier, and sole member of Team Jakaz-X-treme... :twofinger
T-RO is offline  
Sponsored Links
Advertisement
 
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Sportbikes.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Need some help troubleshooting . . . . fishnride Florida 16 02-11-2009 09:58 PM
Need Troubleshooting Help Lucky_Devil FZ6/FZ6R 11 07-07-2007 05:27 PM
Oil and troubleshooting??? plz help Dsc4twenty Help Me Fix It 5 06-16-2007 11:04 AM
Charging System Troubleshooting Chart -- Any Bike jim schmidt Help Me Fix It 0 04-26-2007 12:37 PM
TLS Troubleshooting Help Eastwoody Suzuki Sportbikes 9 09-11-2002 09:06 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome