maintenance on a kaw zx7-r - Sportbikes.net
General Sportbikes This area is for sport bike discussion in general. Topics that don't really belong anywhere else can go here. Questions can be answered and addressed to fully understand certain aspects of the sport. If your question is manufacturer specific please post it there.
Sponsored by: TCX Boots

User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 18 (permalink) Old 09-03-2009, 01:37 AM Thread Starter
 
Join Date: Sep 2009
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Question maintenance on a kaw zx7-r

ok sorry about all the bull crap post i was making about what bike i wanted to buy went i went with a 1995 kaw zx7-r has been Ported and Polished, Carburetor Jetted for MUZZY Exhaust , Stage 1, 30 over,
so far its nice and strong has 18000 miles i paid 2200 chrome frame nice paint very strong and fast special for older bike anyhow i have two questions i hope this is the right spot for these questions"
when i really get on the gas hard there is some flames coming out of the tail pipe i really hammered it and could see the flames but just riding normaly and going through the gears nothing what is this ? ? please help

also the speedo is not working could it just be the cable the rpms gage is working and also the temp gage is workign fine thanks in advance for the info

and sorry about the gramer and no periods lol
rich
thanks
ghetto_ken_doll is offline  
Sponsored Links
Advertisement
 
post #2 of 18 (permalink) Old 09-03-2009, 03:31 AM
500 G.P. Champion
 
univurs's Avatar
 
Join Date: Jul 2008
Location: Hollywood, CA
Age: 32
Posts: 1,255
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
ZX7R for a first bike?

The flames could be because its running to rich, due to the jet kit.

The speedo...check the cennections with the wires look around for anything broken, frayed wires. Was it working when you test rode it?

The bike seems raced. With the exhaust and jet kit, port and polished intake? Those aren't good signs.

Has it ever been on a track?

2008 ninja 650 Sold/2005 zzr600 Sold
univurs is offline  
post #3 of 18 (permalink) Old 09-03-2009, 08:49 AM Thread Starter
 
Join Date: Sep 2009
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
no

hey no the zx7 is not my first bike i have had a 99gsxr750 a 1999 honda cbr600 and my first bike was a 1989 yamaha fzr600 my 750 was built cause i need power lol this bike is nice o far what can i do about the flames i figures it was because of the jet kit but will it hurt the bike my gsxr was jetted but i did not have this problem if i could post or know how to post a pic i would to see if 2000 grand was to much
yes it has been on the track im gonna baby it and do some work on it just not sure what i can do to make sure it last a while at least two years is all i care to get out of the bike
ghetto_ken_doll is offline  
 
post #4 of 18 (permalink) Old 09-03-2009, 08:59 AM
Superbike Racer
 
badbowtie's Avatar
 
Join Date: Jun 2004
Location: Windsor Ontario
Age: 37
Posts: 213
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Assuming they used a similar set up for the speedo like the 96-03 ones it is cable driven off the front wheel. Mine had issues where the cable came undo from the the cluster thus the speedo didnt work. hard to see with all the stuff around it tho.

As for the flames id start by finding out what jet kit was used. Dynojet requires drilling the slides while factory pro does not.

for really good tech info check out http://www.redmonkey.com. zx7r specific site with tons of info, just make sure you fill in your profile there kinda nazi about it.
badbowtie is offline  
post #5 of 18 (permalink) Old 09-03-2009, 11:17 AM
500 GP Racer
 
Mukky's Avatar
 
Join Date: Jun 2008
Location: Michigan
Age: 31
Posts: 794
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
i dont read you posts because you dont use any punctuation what so ever and it makes it very hard to read plus you clerly dont no howz to spelz and no onez can read what you type please for the love of god learn to spell and use punctuation its really not that hard a period here and a comma there
Mukky is offline  
post #6 of 18 (permalink) Old 09-03-2009, 12:36 PM
The cake is a lie
 
Rhetorik's Avatar
 
Join Date: Apr 2008
Location: Ottawa ON Canada
Age: 33
Posts: 10,152
Thanks: 1,146
Thanked 2,641 Times in 1,470 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
 
Garage
Quote:
Originally Posted by Mukky View Post
i dont read you posts because you dont use any punctuation what so ever and it makes it very hard to read plus you clerly dont no howz to spelz and no onez can read what you type please for the love of god learn to spell and use punctuation its really not that hard a period here and a comma there
You're a decent poster, but to be honest you'd be alot better if you didn't bitch about pretty much every single person that doesn't write on the forums as if they're writing essays.

OP - bring it in to a shop, something you should have done before buying the bike. Sounds like a whole mish-mash of shit going on from (most-likely) poorly thought out and added "upgrades", and the bike ridden pretty hard.
Rhetorik is offline  
post #7 of 18 (permalink) Old 09-03-2009, 01:01 PM
hus
Supersport Racer
 
hus's Avatar
 
Join Date: Aug 2009
Location: Alabama
Age: 41
Posts: 197
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
I had a 94 ZX-750 and a 96 ZX7R. I had quite a few problems with the 94. Could never get the jetting right and I had major fork seal issues. The 96 was a totally different bike. Everything fit together better, throttle response was pretty solid, and other than being such a heavy bike for it's power it was one of the best bikes I've owned. However, once we took all the stock exhaust stuff off and reworked the jets the flame thing started. Back then getting a proper tune on a 96 ZX7R was few and far between. So, we put the stock header back on and bolted on a slip-on and I had no more problems with flames.
hus is offline  
post #8 of 18 (permalink) Old 09-03-2009, 03:11 PM Thread Starter
 
Join Date: Sep 2009
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
thanks

thanks for the story i hope i can get it fixed
ghetto_ken_doll is offline  
post #9 of 18 (permalink) Old 09-03-2009, 03:17 PM
Hardass!
 
beowulf2k's Avatar
 
Join Date: Sep 2004
Location: San Antonio,TX
Posts: 8,085
Thanks: 111
Thanked 410 Times in 248 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
 
Heya Ken,

Sounds like you might be getting too much fuel in the carb's. Is it bogging? Either way, jetting for a pipe is recommended simply for the fuel/air issues-but sounds like your carbs are whacked out.
Get them professionally jetted and your problems should be cured. Just one thing-If you do NOT get it fixed, you will burn a valve or a piston FOR SURE!
beowulf2k is offline  
post #10 of 18 (permalink) Old 09-03-2009, 05:29 PM
500 GP Racer
 
Mukky's Avatar
 
Join Date: Jun 2008
Location: Michigan
Age: 31
Posts: 794
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by Rhetorik View Post
You're a decent poster, but to be honest you'd be alot better if you didn't bitch about pretty much every single person that doesn't write on the forums as if they're writing essays.

OP - bring it in to a shop, something you should have done before buying the bike. Sounds like a whole mish-mash of shit going on from (most-likely) poorly thought out and added "upgrades", and the bike ridden pretty hard.
I don't mean to bitch so much about grammar. But every post this guy makes takes me like 15 mins to decipher what he is trying to say. All I ask is for a few periods here and there to help break the sentences up a little.
Mukky is offline  
post #11 of 18 (permalink) Old 09-03-2009, 11:16 PM Thread Starter
 
Join Date: Sep 2009
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
thanks

thanks for the info about the carbs it was done by a shop i saw the reciept and it was serviced in 08 new plugs and wires and stuff let me ask yall this.
should i pay 100 to have the bike looked over from top to bottom?? he says he will do a compression test and a few other test to make sure the bike is running right!! what do you think ? i work on cars but not on bikes ill do like the brakes and stuff, and that reminds me the dam speedo cable keeps breaking could that mean its locked up at the wheel like i install it and i push the bike forward to see if its gonna make the speed gage go up and snap its like its twisting on one end and sticking on the other any ideas?????? thanks
hey guys here is my bike the one i bought two days ago paid 2600 was that to much

Last edited by ghetto_ken_doll; 09-05-2009 at 08:30 PM.
ghetto_ken_doll is offline  
post #12 of 18 (permalink) Old 09-03-2009, 11:46 PM
500 G.P. Champion
 
univurs's Avatar
 
Join Date: Jul 2008
Location: Hollywood, CA
Age: 32
Posts: 1,255
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by ghetto_ken_doll View Post
thanks for the info about the carbs it was done by a shop i saw the reciept and it was serviced in 08 new plugs and wires and stuff let me ask yall this.
should i pay 100 to have the bike looked over from top to bottom?? he says he will do a compression test and a few other test to make sure the bike is running right!! what do you think ? i work on cars but not on bikes ill do like the brakes and stuff, and that reminds me the dam speedo cable keeps breaking could that mean its locked up at the wheel like i install it and i push the bike forward to see if its gonna make the speed gage go up and snap its like its twisting on one end and sticking on the other any ideas?????? thanks
hey guys here is my bike the one i bought two days ago paid 2600 was that to much
It looks sweet!

Your inner speedo cable broke. Buy one cheap on ebay or at a online store (I'm sure you could buy one new) take it off on both ends and inspect it. If one side spins and the other doesn't, then it snapped.

More pics pleaze

EDIT: you didn't get ripped off. 2600 for that bike with those miles and those looks is a good deal.


Now if the damn shit had a rod-Knock then you got screwed. But you say it runs good despite the flames then its good

2008 ninja 650 Sold/2005 zzr600 Sold

Last edited by univurs; 09-03-2009 at 11:52 PM.
univurs is offline  
post #13 of 18 (permalink) Old 09-04-2009, 01:05 AM
 
Join Date: Aug 2009
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Nice bike. I'm sure you know this, but you need to assume it needs EVERY aspect of maintenance performed, to be safe. Change all fluids, lube everything, check torques (especially with that mileage) and I'm betting those carbs might need attention too. If it were my bike, I would pull the carbs and rebuild them.
Scream And Fly is offline  
post #14 of 18 (permalink) Old 09-04-2009, 01:34 AM
Hardass!
 
beowulf2k's Avatar
 
Join Date: Sep 2004
Location: San Antonio,TX
Posts: 8,085
Thanks: 111
Thanked 410 Times in 248 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
 
Quote:
Originally Posted by Mukky View Post
I don't mean to bitch so much about grammar. But every post this guy makes takes me like 15 mins to decipher what he is trying to say. All I ask is for a few periods here and there to help break the sentences up a little.

Yeah you do mean to bitch because you are doing it! We have enough whiners and moaners on SBN-but at least we slap em to whine and moan-you are doing it over a period or comma? gimme a break. Knowing how to read should suffice, taking 15 minutes to deciper is just dumb on your part.
beowulf2k is offline  
post #15 of 18 (permalink) Old 09-04-2009, 01:37 AM
Hardass!
 
beowulf2k's Avatar
 
Join Date: Sep 2004
Location: San Antonio,TX
Posts: 8,085
Thanks: 111
Thanked 410 Times in 248 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
 
Compression test? that is not the answer. You have too much unburnt fuel in the carbs. Lack of compression wont send fire to the ehaust.
beowulf2k is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Sportbikes.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
GT250R Maintenance eazy Hyosung 9 07-22-2013 01:35 PM
F/S 1993 Kawasaki ZX7 Showbike tims210 Bikes For Sale 9 09-05-2009 08:39 AM
Bike Maintenance kf4mtw Florida 13 07-27-2009 03:53 PM
Just a few maintenance q's Grimy ZZR-600 6 08-28-2007 07:57 PM
Fairings from a 96-03 ZX7 on a 94 ZXR 750? rsrxx ZX-7R 2 10-04-2004 12:51 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome