tail light/brake light problem - Sportbikes.net
Suzuki Sportbikes GSX-1300R - Hayabusa, GSX-R1000, GSX-R750, GSX-R600, TL1000R/S, Katana, GS500F, Bandit, SV Series, RG500

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 07-28-2007, 05:49 PM Thread Starter
GIGGITY GIGGITY
 
Join Date: May 2006
Location: right over those hills
Age: 29
Posts: 155
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Exclamation tail light/brake light problem

i got a problem on my '07 gsxr 750. when i apply the brakes on the lever/foot the brake lights don't go on. i checked the fuses including the main fuse. checked the connectors going to the rear lights and other harnesses/connectors. i thought it had something to do with the rear fender removed, but i connected it back and the brake light still doesn't work. i know it was working last week because i saw it reflecting on someone's car. any idea what the problem could be?
soobieajax325 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 07-28-2007, 07:16 PM
World Superbike Racer
 
brent98rt's Avatar
 
Join Date: May 2007
Location: Arizona
Age: 35
Posts: 579
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by soobieajax325
i got a problem on my '07 gsxr 750. when i apply the brakes on the lever/foot the brake lights don't go on. i checked the fuses including the main fuse. checked the connectors going to the rear lights and other harnesses/connectors. i thought it had something to do with the rear fender removed, but i connected it back and the brake light still doesn't work. i know it was working last week because i saw it reflecting on someone's car. any idea what the problem could be?

did you check the bulb?
do your turn signals work?

2006 LTR450 #701 Firebird Cup Beg. class points leader
1997 CR125
1999 CR80(For Sale)
brent98rt is offline  
post #3 of 5 (permalink) Old 07-30-2007, 06:52 PM
you smokin track?
 
singletrackmind's Avatar
 
Join Date: Jul 2006
Location: Kennett Square, PA
Age: 38
Posts: 868
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
I have both a 05 1k and a 05 600. the switch is the same for both and I beleive that the switch is similar for most suzuki's. check for the spring attached to the break pedal. there is a black housing that is normaly closed but opens to turn on the brake light. also make sure the switch is not stuck in any one position. my 6 has aftermarket rearsets and doesen't have a mount for the switch. the only time i use my rear is if I run off at the track so it not working is not a issue.
matt

you don't know when, you don't know where, but you will know why.
Rider Resume:
http://www.sportbikes.net/forums/new...esumes-10.html


Tire mounting and balancing, small puncture repair, lighting, and scheduled maintenance. services available 24/7. I work for beer.610-299-4017
singletrackmind is offline  
post #4 of 5 (permalink) Old 07-30-2007, 08:16 PM
old member
 
RayOSV's Avatar
 
Join Date: Jun 2003
Location: San Jose, CA
Posts: 13,079
Thanks: 39
Thanked 113 Times in 87 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
If the brake light works with the front brake, the problem is probably in the rear brake switch as posted above. If the brake light doesn't work with the front brake, check the bulb. Is it LED? If yes, could be the control board. Is it a dual filament bulb? If yes, does the tail light part of it work?

Moderator - New riders, help me fix it and riders' gear. Send me a PM with questions, suggestions, or issues.

Never out-ride your ability to react (even stop) within the distance you can see (at least on the street).

Great content for new riders at:

http://www.bestbeginnermotorcycles.com/
RayOSV is offline  
post #5 of 5 (permalink) Old 07-31-2007, 03:33 PM Thread Starter
GIGGITY GIGGITY
 
Join Date: May 2006
Location: right over those hills
Age: 29
Posts: 155
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Quote:
Originally Posted by singletrackmind
I have both a 05 1k and a 05 600. the switch is the same for both and I beleive that the switch is similar for most suzuki's. check for the spring attached to the break pedal. there is a black housing that is normaly closed but opens to turn on the brake light. also make sure the switch is not stuck in any one position. my 6 has aftermarket rearsets and doesen't have a mount for the switch. the only time i use my rear is if I run off at the track so it not working is not a issue.
matt
yup you were right about the spring on the brake pedal. i adjusted it and now it works fine again. thanks for all the help fellas. i appreciate it
soobieajax325 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Sportbikes.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
im pissed Dont bake your tail lights !! RobTheGreat Florida 25 07-20-2007 12:48 PM
Tail light for '06? darkbluexplorer FZ6/FZ6R 2 06-21-2007 02:47 AM
01' F4i No Tail Running light suicidal Help Me Fix It 0 06-17-2007 11:13 AM
FZ6 LED light kit...no brake light GangstaSean676 Help Me Fix It 2 06-11-2007 05:18 PM
led tail light? xrookiex FZ6/FZ6R 2 03-21-2007 09:57 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome