99 ZX6R Carb problem, stalls when the throttle is touched - Sportbikes.net
Help Me Fix It A great place to post any problems you may be having while working on your motorcycle. Most of us are do-it-yourselfers so this is a great way to share any information pertaining to fixing something or adding something on.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 03-27-2008, 07:23 PM Thread Starter
SBN Rookie
 
xstartup00c's Avatar
 
Join Date: Mar 2008
Location: Ohio
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
99 ZX6R Carb problem, stalls when the throttle is touched

Well Im the proud owner of a 99 zx6r and after owning a zx7r in the past I cant wait to ride it. Theres one problem. It will start idle and run fine but soon as I touch the throttle it stalls. If I turn the idle up and use the choke for a second it will rev up just fine but only stalls with the throttle. At the same time I give it gas I hear air come out of the airbox. Like a spuff sound. I did notice the fuel pump just keeps ticking when the bikes idling. Over and over. Im not sure if thats normal. I never noticed anything like it on any of my other bikes. Could it be getting to much gas?
xstartup00c is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 03-27-2008, 08:05 PM
500 GP Racer
 
zzr6oo187's Avatar
 
Join Date: Mar 2007
Location: daytona beach florida
Posts: 929
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
sounds like you're not getting enough air, Or to much fuel. might want to have the carbs cleaned and tuned,might also want to check the fuel rail for cracks or the round rubber couplers that hold them to your engine
zzr6oo187 is offline  
post #3 of 7 (permalink) Old 03-27-2008, 08:40 PM Thread Starter
SBN Rookie
 
xstartup00c's Avatar
 
Join Date: Mar 2008
Location: Ohio
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
I was thinking to much fuel myself. Anyone know if the fuel pump is supposed to run all the time? It's a constant ticking. Almost sounds like a taping valve but its the pump. There is no gas leaking from the carbs or anything so im not sure.
xstartup00c is offline  
post #4 of 7 (permalink) Old 03-27-2008, 09:55 PM
Hardass!
 
beowulf2k's Avatar
 
Join Date: Sep 2004
Location: San Antonio,TX
Posts: 8,070
Thanks: 107
Thanked 410 Times in 248 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
You should start from the beginning.
1. Fuel Pressure-Is there enough? My ZX7 use to "kink" the hoses when I put the tank back on. Check for kinks. Also check the fuel filter. (the problem is not too much fuel)
2. Air-check for constriction, you should hear air from the front air intake, not the airbox-kinda sorta.
3. last but not least if anything, fill the carbs up, take the tank off, tank the filters off and run it. you should get a good 15-20 seconds of fuel-rev and see if its a fuel or air problem.
4. your plugs might be too cold. get hotter plugs

Last but not least-take it to a mechanic.
beowulf2k is offline  
post #5 of 7 (permalink) Old 03-27-2008, 10:19 PM
500 GP Racer
 
zzr6oo187's Avatar
 
Join Date: Mar 2007
Location: daytona beach florida
Posts: 929
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
i'm thinkin air restriction and it's just dumping fuel. and the fuel pump is more of a pulse. If you need one i have it in the garage and most other stuff too
zzr6oo187 is offline  
post #6 of 7 (permalink) Old 03-28-2008, 07:24 AM
Speed Racer
 
Tuffguy #2's Avatar
 
Join Date: Jun 2004
Location: Farmington, CT
Age: 37
Posts: 1,650
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Check the slop in your throttle.

My friends brand spanking new ZX6 would bog right off of the throttle and almost die. The genuses at the dealer left so much slop in the throttle that it was actually bogging the engine out. Throttles are a push/pull system.

If thats not it,,,do whateveryone else suggested.

Ron Paul supports the John Birch Society
Video of RP talking at the JBS 50th anniversary. http://www.jbs.org/index.php/about/jbs-50th-anniversary
Advocating personal responsibility and less government for decades, with no political affiliation.
www.jbs.org
http://www.takeyourmoneyback.com/
Tuffguy #2 is offline  
post #7 of 7 (permalink) Old 03-28-2008, 09:51 AM Thread Starter
SBN Rookie
 
xstartup00c's Avatar
 
Join Date: Mar 2008
Location: Ohio
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
I pulled the fuel filter off and it's fine. I had the tank on the back of the bike still hooked up and when it's running the fuel pump sounds like a machine gun and is pumping alot of gas into the carbs. It's more of a rapid pulse if anything. I would think that it would pulse once every 30 seconds or so but I have no idea. When I leave work im going to get a new set of plugs and put them in since im taking the airbox apart anyways. I have a feeling the fuel pump isnt hooked up right. I never had a bike that had the fuel pump pulse over and over when you try to start it in gear without pulling the clutch in and the kickstand down at that.But the only noise I hear when I try is that fuel pump pumping away. What's everyones opinion on a stuck float? Could that play a role?
xstartup00c is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Sportbikes.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Throttle Position Sensor Issues (Are you Experiencing Poor Idle/Mileage, or Stalls?) FZ6R FZ6/FZ6R 525 05-24-2015 10:59 PM
A guide for learning wheelies. Justin726 Stunterz Corner 188 07-19-2011 10:05 AM
Long time problem with one valve in cyl1? Pix id4rox Help Me Fix It 6 08-29-2009 05:13 PM
Problem with my bike! HELP Please! aberchonbie FZ6/FZ6R 22 04-30-2007 05:34 PM
carb question problem on 04 500r 500r Help Me Fix It 4 09-17-2004 04:02 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome